Category: News



Urgent security advisory: #Heartbleed – openSSL Vulnerability

This is an urgent security advisory regarding an openSSL security vulnerability CVE-2014-0160, which was revealed today to be a catastrophic, remotely exploitable security vulnerability affecting all applications utilizing openSSL. The vulnerability was announced via the domain http://www.heartbleed.com Which versions are affected is unclear: The Heartbleed website says everything above 1.0.0+ We also read an unconfirmed report … [Read more]



Office Phones Down

Due to a power outage at our office our phone system is currently and we are currently unable to make or receive phone calls. We are working with our building management to determine how quickly this problem will be resolved. Until then our support staff will be replying to support tickets. We will update this … [Read more]